{"action":"Upgrade paste to 1.7.4 or later.","affected":[{"fixed":"1.7.4","introduced":"0"}],"component":"paste","cve_ids":["CVE-2010-2477"],"ecosystem":"PyPI","epss":0.02288,"exploited":false,"fixed_versions":["1.7.4"],"ghsa_id":"GHSA-7gfc-2v6g-6w9f","id":"tcs_01M5KF5XBXJ9W4TRE0JF0F3GYC","modified_at":"2024-10-09T20:50:53.616953Z","published_at":"2022-05-17T05:45:29Z","references":["https://osv.dev/vulnerability/GHSA-7gfc-2v6g-6w9f","https://nvd.nist.gov/vuln/detail/CVE-2010-2477","https://github.com/cdent/paste/commit/4910493c62f369a3222357af09450930e4c93f5e","https://github.com/cdent/paste","https://github.com/pypa/advisory-database/tree/main/vulns/paste/PYSEC-2010-29.yaml","https://web.archive.org/web/20111227133546/http://secunia.com/advisories/42500","https://web.archive.org/web/20120527154041/http://www.securityfocus.com/bid/41160","http://bitbucket.org/ianb/paste/changeset/fcae59df8b56","http://groups.google.com/group/paste-users/browse_thread/thread/3b3fff3dadd0b1e5?pli=1","http://groups.google.com/group/pylons-discuss/msg/8c256dc076a408d8?dmode=source&output=gplain","http://marc.info/?l=oss-security&m=127785414818815&w=2","http://marc.info/?l=oss-security&m=127792576822169&w=2","http://pylonshq.com/articles/archives/2010/6/paste_174_released_addresses_xss_security_hole","http://www.ubuntu.com/usn/USN-1026-1"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-7gfc-2v6g-6w9f","url":"https://osv.dev/vulnerability/GHSA-7gfc-2v6g-6w9f"}],"summary":"Paste is vulnerable to Cross-site Scripting via vectors involving a 404 status code"}