{"action":"Upgrade moodle/moodle to 4.1.12 or later.","affected":[{"fixed":"4.1.12","introduced":"0"},{"fixed":"4.2.9","introduced":"4.2.0-beta"},{"fixed":"4.3.6","introduced":"4.3.0-beta"},{"fixed":"4.4.2","introduced":"4.4.0-beta"}],"component":"moodle/moodle","cve_ids":["CVE-2024-43436"],"ecosystem":"Packagist","epss":0.00796,"exploited":false,"fixed_versions":["4.1.12","4.2.9","4.3.6","4.4.2"],"ghsa_id":"GHSA-mx26-62xm-2p83","id":"tcs_01M5KF5XKB0ZS1JH3AQ20DSH46","modified_at":"2025-08-06T06:42:13.925769Z","published_at":"2024-11-07T15:31:52Z","references":["https://osv.dev/vulnerability/GHSA-mx26-62xm-2p83","https://nvd.nist.gov/vuln/detail/CVE-2024-43436","https://bugzilla.redhat.com/show_bug.cgi?id=2304264","https://github.com/moodle/moodle","https://moodle.org/mod/forum/discuss.php?d=461206"],"severity":{"label":"high","score":7.2},"sources":[{"source":"osv","source_id":"GHSA-mx26-62xm-2p83","url":"https://osv.dev/vulnerability/GHSA-mx26-62xm-2p83"}],"summary":"Moodle vulnerable to site administration SQL injection via XMLDB editor"}