{"action":"Upgrade tensorflow-gpu to 2.3.4 or later.","affected":[{"fixed":"2.3.4","introduced":"0"},{"fixed":"2.4.3","introduced":"2.4.0"},{"fixed":"2.5.1","introduced":"2.5.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-37674"],"ecosystem":"PyPI","epss":0.00179,"exploited":false,"fixed_versions":["2.3.4","2.4.3","2.5.1"],"ghsa_id":"GHSA-7ghq-fvr3-pj2x","id":"tcs_01M5KF5Y9EQEGJDMMSK2R3NM4Y","modified_at":"2026-07-08T06:29:02.787783792Z","published_at":"2021-08-25T14:41:33Z","references":["https://osv.dev/vulnerability/GHSA-7ghq-fvr3-pj2x","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-7ghq-fvr3-pj2x","https://nvd.nist.gov/vuln/detail/CVE-2021-37674","https://github.com/tensorflow/tensorflow/commit/136b51f10903e044308cf77117c0ed9871350475","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-587.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-785.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-296.yaml","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2021-068.md"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"GHSA-7ghq-fvr3-pj2x#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-7ghq-fvr3-pj2x"}],"summary":"Incomplete validation in `MaxPoolGrad`"}