{"action":"Upgrade topthink/framework to 6.0.14 or later.","affected":[{"fixed":"6.0.14","introduced":"0"}],"component":"topthink/framework","cve_ids":["CVE-2022-47945"],"ecosystem":"Packagist","epss":0.30237,"exploited":false,"fixed_versions":["6.0.14"],"ghsa_id":"GHSA-p4qr-vq2g-22wp","id":"tcs_01M5KF619R29E34RRPJPN4EVVT","modified_at":"2025-04-15T16:19:40.569908Z","published_at":"2022-12-23T21:30:17Z","references":["https://osv.dev/vulnerability/GHSA-p4qr-vq2g-22wp","https://nvd.nist.gov/vuln/detail/CVE-2022-47945","https://github.com/top-think/framework/commit/c4acb8b4001b98a0078eda25840d33e295a7f099","https://github.com/top-think/framework","https://github.com/top-think/framework/compare/v6.0.13...v6.0.14","https://tttang.com/archive/1865"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-p4qr-vq2g-22wp","url":"https://osv.dev/vulnerability/GHSA-p4qr-vq2g-22wp"}],"summary":"ThinkPHP Framework vulnerable to remote code execution"}