{"action":"Upgrade @babel/traverse to 7.23.2 or later.","affected":[{"fixed":"7.23.2","introduced":"0"},{"fixed":"8.0.0-alpha.4","introduced":"8.0.0-alpha.0"}],"component":"@babel/traverse","cve_ids":["CVE-2023-45133"],"ecosystem":"npm","epss":0.00525,"exploited":false,"fixed_versions":["7.23.2","8.0.0-alpha.4"],"ghsa_id":"GHSA-67hx-6x53-jw92","id":"tcs_01M5KF64NM03NPW6Z45GTC46TC","modified_at":"2026-09-10T03:50:03.372029556Z","published_at":"2023-10-16T13:55:36Z","references":["https://osv.dev/vulnerability/GHSA-67hx-6x53-jw92","https://github.com/babel/babel/security/advisories/GHSA-67hx-6x53-jw92","https://nvd.nist.gov/vuln/detail/CVE-2023-45133","https://github.com/babel/babel/pull/16033","https://github.com/babel/babel/commit/b13376b346946e3f62fc0848c1d2a23223314c82","https://babeljs.io/blog/2023/10/16/cve-2023-45133","https://github.com/babel/babel","https://github.com/babel/babel/releases/tag/v7.23.2","https://github.com/babel/babel/releases/tag/v8.0.0-alpha.4","https://lists.debian.org/debian-lts-announce/2023/10/msg00026.html","https://www.debian.org/security/2023/dsa-5528"],"severity":{"label":"critical","score":9.3},"sources":[{"source":"osv","source_id":"GHSA-67hx-6x53-jw92","url":"https://osv.dev/vulnerability/GHSA-67hx-6x53-jw92"}],"summary":"Babel vulnerable to arbitrary code execution when compiling specifically crafted malicious code"}