{"action":"Upgrade json-logic-js to 2.0.1 or later.","affected":[{"fixed":"2.0.1","introduced":"0"}],"component":"json-logic-js","cve_ids":["CVE-2021-4329"],"ecosystem":"npm","epss":0.02205,"exploited":false,"fixed_versions":["2.0.1"],"ghsa_id":"GHSA-67j4-2mh6-8627","id":"tcs_01M5KF654YRMJR2DSXVTF4BF26","modified_at":"2024-11-22T00:12:07.253048Z","published_at":"2023-03-05T21:30:15Z","references":["https://osv.dev/vulnerability/GHSA-67j4-2mh6-8627","https://nvd.nist.gov/vuln/detail/CVE-2021-4329","https://github.com/jwadhams/json-logic-js/pull/98","https://github.com/jwadhams/json-logic-js/commit/c1dd82f5b15d8a553bb7a0cfa841ab8a11a9c227","https://github.com/jwadhams/json-logic-js","https://github.com/pypa/advisory-database/tree/main/vulns/json-logic/PYSEC-2023-209.yaml","https://vuldb.com/?ctiid.222266","https://vuldb.com/?id.222266"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-67j4-2mh6-8627","url":"https://osv.dev/vulnerability/GHSA-67j4-2mh6-8627"}],"summary":"json-logic-js Command Injection vulnerability"}