{"action":"Upgrade github.com/imgproxy/imgproxy/v3 to 3.15.0 or later.","affected":[{"fixed":"3.15.0","introduced":"0"}],"component":"github.com/imgproxy/imgproxy/v3","cve_ids":["CVE-2023-30019"],"ecosystem":"Go","epss":0.02214,"exploited":false,"fixed_versions":["3.15.0"],"ghsa_id":"GHSA-9x7h-ggc3-xg47","id":"tcs_01M5KF6BW000JQGYACQJG2X879","modified_at":"2024-08-20T20:59:06.200328Z","published_at":"2023-05-08T15:30:20Z","references":["https://osv.dev/vulnerability/GHSA-9x7h-ggc3-xg47","https://nvd.nist.gov/vuln/detail/CVE-2023-30019","https://github.com/imgproxy/imgproxy/commit/1a9768a2c682e88820064aa3d9a05ea234ff3cc4","https://breakandpray.com/cve-2023-30019-ssrf-in-imgproxy","https://github.com/imgproxy/imgproxy","https://github.com/imgproxy/imgproxy/blob/ee9e8f0cb101ec22318caffd552a23cc0548d5ce/imagedata/download.go#L142"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-9x7h-ggc3-xg47","url":"https://osv.dev/vulnerability/GHSA-9x7h-ggc3-xg47"}],"summary":"imgproxy is vulnerable to Server-Side Request Forgery"}