{"action":"Upgrade github.com/mattermost/mattermost-server to 4.1.2 or later.","affected":[{"fixed":"4.1.2","introduced":"0"},{"fixed":"4.2.1","introduced":"4.2.0"},{"fixed":"4.3.0","introduced":"4.3.0-rc1"}],"component":"github.com/mattermost/mattermost-server","cve_ids":["CVE-2017-18877"],"ecosystem":"Go","epss":0.0069,"exploited":false,"fixed_versions":["4.1.2","4.2.1","4.3.0"],"ghsa_id":"GHSA-9x8x-w6g5-hx4w","id":"tcs_01M5KF6CC5RWSBYWMYD8VQDBYS","modified_at":"2025-12-09T17:57:32.691157Z","published_at":"2022-05-24T17:21:03Z","references":["https://osv.dev/vulnerability/GHSA-9x8x-w6g5-hx4w","https://nvd.nist.gov/vuln/detail/CVE-2017-18877","https://github.com/mattermost/mattermost","https://mattermost.com/security-updates"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-9x8x-w6g5-hx4w","url":"https://osv.dev/vulnerability/GHSA-9x8x-w6g5-hx4w"}],"summary":"Mattermost Server is vulnerable to XSS attacks against an OAuth 2.0 allow/deny page"}