{"action":"Upgrade vyper to 0.3.2 or later.","affected":[{"fixed":"0.3.2","introduced":"0"}],"component":"vyper","cve_ids":["CVE-2022-24787"],"ecosystem":"PyPI","epss":0.01029,"exploited":false,"fixed_versions":["0.3.2"],"ghsa_id":"GHSA-7vrm-3jc8-5wwm","id":"tcs_01M5KF6NYM0HDH573X3QH6DMVC","modified_at":"2024-12-05T05:47:08.393067Z","published_at":"2022-04-04T21:40:45Z","references":["https://osv.dev/vulnerability/GHSA-7vrm-3jc8-5wwm","https://github.com/vyperlang/vyper/security/advisories/GHSA-7vrm-3jc8-5wwm","https://github.com/vyperlang/vyper/commit/2c73f8352635c0a433423a5b94740de1a118e508","https://github.com/pypa/advisory-database/tree/main/vulns/vyper/PYSEC-2022-196.yaml","https://github.com/vyperlang/vyper"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-7vrm-3jc8-5wwm","url":"https://osv.dev/vulnerability/GHSA-7vrm-3jc8-5wwm"}],"summary":"Incorrect Comparison in Vyper"}