{"action":"Upgrade blamer to 1.0.4 or later.","affected":[{"fixed":"1.0.4","introduced":"0"}],"component":"blamer","cve_ids":["CVE-2023-26143"],"ecosystem":"npm","epss":0.01122,"exploited":false,"fixed_versions":["1.0.4"],"ghsa_id":"GHSA-6f9p-g466-f8v8","id":"tcs_01M5KF6SGNX6ZSKH1MJ3WQAJSN","modified_at":"2025-09-26T21:40:42Z","published_at":"2023-09-19T06:30:17Z","references":["https://osv.dev/vulnerability/GHSA-6f9p-g466-f8v8","https://nvd.nist.gov/vuln/detail/CVE-2023-26143","https://github.com/kucherenko/blamer/commit/0965877f115753371a2570f10a63c455d2b2cde3","https://gist.github.com/lirantal/14c3686370a86461f555d3f0703e02f9","https://github.com/kucherenko/blamer","https://security.snyk.io/vuln/SNYK-JS-BLAMER-5731318"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-6f9p-g466-f8v8","url":"https://osv.dev/vulnerability/GHSA-6f9p-g466-f8v8"}],"summary":"blamer vulnerable to Arbitrary Argument Injection via the blameByFile() API"}