{"action":"Upgrade uni2ts to 2.0.0 or later.","affected":[{"fixed":"2.0.0","introduced":"0"}],"component":"uni2ts","cve_ids":["CVE-2026-22584"],"ecosystem":"PyPI","epss":0.00436,"exploited":false,"fixed_versions":["2.0.0"],"ghsa_id":"GHSA-7x99-8x99-xc54","id":"tcs_01M5KF6VD94Y4HMQRGEAJA00YY","modified_at":"2026-06-29T12:26:45.499152652Z","published_at":"2026-01-10T00:30:30Z","references":["https://osv.dev/vulnerability/GHSA-7x99-8x99-xc54","https://nvd.nist.gov/vuln/detail/CVE-2026-22584","https://github.com/SalesforceAIResearch/uni2ts/pull/218","https://github.com/SalesforceAIResearch/uni2ts/commit/7f2d51dd729de018f0f22504f39a8475c6fed1c4","https://github.com/SalesforceAIResearch/uni2ts","https://github.com/SalesforceAIResearch/uni2ts/releases/tag/2.0.0","https://help.salesforce.com/s/articleView?id=005239354&type=1"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-7x99-8x99-xc54","url":"https://osv.dev/vulnerability/GHSA-7x99-8x99-xc54"}],"summary":"Salesforce Uni2TS has a Code Injection vulnerability"}