{"action":"Upgrade pwntools to 4.3.1 or later.","affected":[{"fixed":"4.3.1","introduced":"0"}],"component":"pwntools","cve_ids":["CVE-2020-28468"],"ecosystem":"PyPI","epss":0.04379,"exploited":false,"fixed_versions":["4.3.1"],"ghsa_id":"GHSA-7xc5-ggpp-g249","id":"tcs_01M5KF6VK1DH6QDPV9CBC98ZM0","modified_at":"2024-10-18T22:22:40.219895Z","published_at":"2021-04-20T16:13:24Z","references":["https://osv.dev/vulnerability/GHSA-7xc5-ggpp-g249","https://nvd.nist.gov/vuln/detail/CVE-2020-28468","https://github.com/Gallopsled/pwntools/issues/1427","https://github.com/Gallopsled/pwntools/pull/1732","https://github.com/Gallopsled/pwntools/commit/138188eb1c027a2d0ffa4151511c407d3a001660","https://github.com/Gallopsled/pwntools","https://github.com/advisories/GHSA-7xc5-ggpp-g249","https://github.com/pypa/advisory-database/tree/main/vulns/pwntools/PYSEC-2021-72.yaml","https://snyk.io/vuln/SNYK-PYTHON-PWNTOOLS-1047345"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-7xc5-ggpp-g249","url":"https://osv.dev/vulnerability/GHSA-7xc5-ggpp-g249"}],"summary":"pwntools Server-Side Template Injection (SSTI) vulnerability"}