{"action":"Upgrade tensorflow-cpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29574"],"ecosystem":"PyPI","epss":0.00201,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-828x-qc2p-wprq","id":"tcs_01M5KF706VH20A1CBYSGTEPBHG","modified_at":"2026-07-08T06:29:06.880710681Z","published_at":"2021-05-21T14:26:10Z","references":["https://osv.dev/vulnerability/GHSA-828x-qc2p-wprq","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-828x-qc2p-wprq","https://nvd.nist.gov/vuln/detail/CVE-2021-29574","https://github.com/tensorflow/tensorflow/commit/a3d9f9be9ac2296615644061b40cefcee341dcc4","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-502.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-700.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-211.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-828x-qc2p-wprq#PyPI/tensorflow-cpu","url":"https://osv.dev/vulnerability/GHSA-828x-qc2p-wprq"}],"summary":"Undefined behavior in `MaxPool3DGradGrad`"}