{"action":"Upgrade hyper to 0.14.10 or later.","affected":[{"fixed":"0.14.10","introduced":"0.0.0-0"}],"component":"hyper","cve_ids":["CVE-2021-32715"],"ecosystem":"crates.io","epss":0.01126,"exploited":false,"fixed_versions":["0.14.10"],"ghsa_id":"GHSA-f3pg-qwvg-p99c","id":"tcs_01M5KF74N6NBGAYAPD1BH9T2GT","modified_at":"2026-10-12T18:00:03.463487342Z","published_at":"2021-07-07T12:00:00Z","references":["https://osv.dev/vulnerability/RUSTSEC-2021-0078","https://crates.io/crates/hyper","https://rustsec.org/advisories/RUSTSEC-2021-0078.html","https://github.com/hyperium/hyper/commit/1fb719e0b61a4f3d911562a436a2ff05fd7cb759"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"RUSTSEC-2021-0078","url":"https://osv.dev/vulnerability/RUSTSEC-2021-0078"}],"summary":"Lenient `hyper` header parsing of `Content-Length` could allow request smuggling"}