{"action":"Upgrade actix-http to 2.2.1 or later.","affected":[{"fixed":"2.2.1","introduced":"0.0.0-0"},{"introduced":"3.0.0-0"}],"component":"actix-http","cve_ids":["CVE-2021-38512"],"ecosystem":"crates.io","epss":0.0181,"exploited":false,"fixed_versions":["2.2.1","3.0.0-beta.9"],"ghsa_id":"GHSA-8928-2fgm-6x9x","id":"tcs_01M5KF759B1RG662PV8CA7FK6P","modified_at":"2023-11-08T04:06:27.940101Z","published_at":"2021-06-16T12:00:00Z","references":["https://osv.dev/vulnerability/RUSTSEC-2021-0081","https://crates.io/crates/actix-http","https://rustsec.org/advisories/RUSTSEC-2021-0081.html"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"RUSTSEC-2021-0081","url":"https://osv.dev/vulnerability/RUSTSEC-2021-0081"}],"summary":"Potential request smuggling capabilities due to lack of input validation"}