{"action":"Upgrade codeigniter/framework to 3.0.3 or later.","affected":[{"fixed":"3.0.3","introduced":"0"}],"component":"codeigniter/framework","cve_ids":[],"ecosystem":"Packagist","exploited":false,"fixed_versions":["3.0.3"],"ghsa_id":"GHSA-q9j3-4ghj-6h57","id":"tcs_01M5KF75M9ZD95AND0KW8HAQB5","modified_at":"2024-11-29T05:41:14.070425Z","published_at":"2024-05-15T18:08:27Z","references":["https://osv.dev/vulnerability/GHSA-q9j3-4ghj-6h57","https://github.com/bcit-ci/CodeIgniter/commit/71b1b3f5b2dcc0f4b652e9494e9853b82541ac8c","https://github.com/FriendsOfPHP/security-advisories/blob/master/codeigniter/framework/2015-10-31-1.yaml","https://github.com/bcit-ci/CodeIgniter","https://www.codeigniter.com/user_guide/changelog.html#version-3-0-3"],"severity":{"label":"medium","score":4.7},"sources":[{"source":"osv","source_id":"GHSA-q9j3-4ghj-6h57","url":"https://osv.dev/vulnerability/GHSA-q9j3-4ghj-6h57"}],"summary":"Inadequate XSS Prevention in CodeIgniter/Framework Security Library"}