{"action":"Upgrade cakephp/cakephp to 5.2.12 or later.","affected":[{"fixed":"5.2.12","introduced":"5.2.10"},{"fixed":"5.3.1","introduced":"5.3.0"}],"component":"cakephp/cakephp","cve_ids":["CVE-2026-23643"],"ecosystem":"Packagist","epss":0.00281,"exploited":false,"fixed_versions":["5.2.12","5.3.1"],"ghsa_id":"GHSA-qh8m-9qxx-53m5","id":"tcs_01M5KF7AZ1YP01FAQBHZV9N3D9","modified_at":"2026-02-03T03:11:17.661769Z","published_at":"2026-01-16T21:00:44Z","references":["https://osv.dev/vulnerability/GHSA-qh8m-9qxx-53m5","https://github.com/cakephp/cakephp/security/advisories/GHSA-qh8m-9qxx-53m5","https://nvd.nist.gov/vuln/detail/CVE-2026-23643","https://github.com/cakephp/cakephp/issues/19172","https://github.com/cakephp/cakephp/commit/c842e7f45d85696e6527d8991dd72f525ced955f","https://bakery.cakephp.org/2026/01/14/cakephp_5212.html","https://github.com/cakephp/cakephp","https://github.com/cakephp/cakephp/releases/tag/5.2.12","https://github.com/cakephp/cakephp/releases/tag/5.3.1"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-qh8m-9qxx-53m5","url":"https://osv.dev/vulnerability/GHSA-qh8m-9qxx-53m5"}],"summary":"CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting"}