{"action":"Upgrade flightphp/core to 3.18.1 or later.","affected":[{"fixed":"3.18.1","introduced":"0"}],"component":"flightphp/core","cve_ids":["CVE-2026-42552"],"ecosystem":"Packagist","epss":0.00335,"exploited":false,"fixed_versions":["3.18.1"],"ghsa_id":"GHSA-qrch-52m5-vv85","id":"tcs_01M5KF7JQ8JK3ZG3ZGDP7S87MM","modified_at":"2026-05-14T20:52:30.221554Z","published_at":"2026-05-06T21:39:07Z","references":["https://osv.dev/vulnerability/GHSA-qrch-52m5-vv85","https://github.com/flightphp/core/security/advisories/GHSA-qrch-52m5-vv85","https://nvd.nist.gov/vuln/detail/CVE-2026-42552","https://github.com/flightphp/core/commit/b8dd23aaa828cb289fa3c84e75b2a3717cab50b0","https://github.com/flightphp/core","https://github.com/flightphp/core/releases/tag/v3.18.1"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-qrch-52m5-vv85","url":"https://osv.dev/vulnerability/GHSA-qrch-52m5-vv85"}],"summary":"Flight vulnerable to sensitive information disclosure via default error handler"}