{"action":"Upgrade @aws/lsp-codewhisperer to 0.0.117 or later.","affected":[{"fixed":"0.0.117","introduced":"0"}],"component":"@aws/lsp-codewhisperer","cve_ids":["CVE-2026-12958"],"ecosystem":"npm","epss":0.00191,"exploited":false,"fixed_versions":["0.0.117"],"ghsa_id":"GHSA-6v3r-4p5c-mrp5","id":"tcs_01M5KF7YNGEV47EQGAV0ETQ5Q5","modified_at":"2026-09-24T19:30:05.283632225Z","published_at":"2026-09-24T19:15:39Z","references":["https://osv.dev/vulnerability/GHSA-6v3r-4p5c-mrp5","https://github.com/aws/language-servers/security/advisories/GHSA-6v3r-4p5c-mrp5","https://nvd.nist.gov/vuln/detail/CVE-2026-12958","https://github.com/Amazon-Q-Developer/language-servers/pull/2742","https://github.com/Amazon-Q-Developer/language-servers/commit/6c279b083cc192aa5df1f38c2c185576fd5234f5","https://aws.amazon.com/security/security-bulletins/2026-047-aws","https://github.com/Amazon-Q-Developer/language-servers/releases/tag/agentic-rc-1.69.0","https://github.com/Amazon-Q-Developer/language-servers/releases/tag/lsp-codewhisperer/v0.0.117","https://github.com/aws/language-servers"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"GHSA-6v3r-4p5c-mrp5","url":"https://osv.dev/vulnerability/GHSA-6v3r-4p5c-mrp5"}],"summary":"Language Servers for AWS vulnerable to arbitrary file write"}