{"action":"Upgrade ansible to 2.8.19rc1 or later.","affected":[{"fixed":"2.9.18rc1","introduced":"2.9.0a1"},{"fixed":"2.8.19rc1","introduced":"0"},{"fixed":"2.10.7","introduced":"2.10.0a1"}],"component":"ansible","cve_ids":["CVE-2021-20191"],"ecosystem":"PyPI","epss":0.00349,"exploited":false,"fixed_versions":["2.9.18rc1","2.8.19rc1","2.10.7"],"ghsa_id":"GHSA-8f4m-hccc-8qph","id":"tcs_01M5KF80A4CV1S2TEEKXBA1XQ5","modified_at":"2024-09-10T22:06:37.487770Z","published_at":"2021-06-01T21:38:33Z","references":["https://osv.dev/vulnerability/GHSA-8f4m-hccc-8qph","https://nvd.nist.gov/vuln/detail/CVE-2021-20191","https://github.com/ansible/ansible/pull/73488","https://github.com/ansible/ansible/pull/73489","https://github.com/ansible/ansible/commit/cc82d986c40328d4ae81298a9d287c95a6326bb0","https://github.com/ansible/ansible/commit/d74a1b1d1325af2a24848044cf2858987f5a3ecc","https://access.redhat.com/security/cve/cve-2021-20191","https://bugzilla.redhat.com/show_bug.cgi?id=1916813","https://github.com/advisories/GHSA-8f4m-hccc-8qph","https://github.com/ansible/ansible","https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2021-124.yaml","https://lists.debian.org/debian-lts-announce/2023/12/msg00018.html"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"GHSA-8f4m-hccc-8qph","url":"https://osv.dev/vulnerability/GHSA-8f4m-hccc-8qph"}],"summary":"Insertion of Sensitive Information into Log File in ansible"}