{"action":"Upgrade phpunit/phpunit to 4.8.28 or later.","affected":[{"fixed":"4.8.28","introduced":"4.8.19"},{"fixed":"5.6.3","introduced":"5.0.10"}],"component":"phpunit/phpunit","cve_ids":["CVE-2017-9841"],"ecosystem":"Packagist","epss":0.99999,"exploited":true,"fixed_versions":["4.8.28","5.6.3"],"ghsa_id":"GHSA-r7c9-c69m-rph8","id":"tcs_01M5KF80MGFGEDZ01Q0M8QSSBX","modified_at":"2025-10-22T19:24:09.569632Z","published_at":"2022-03-26T00:19:30Z","references":["https://osv.dev/vulnerability/GHSA-r7c9-c69m-rph8","https://nvd.nist.gov/vuln/detail/CVE-2017-9841","https://github.com/sebastianbergmann/phpunit/pull/1955","https://github.com/sebastianbergmann/phpunit/pull/1956","https://github.com/sebastianbergmann/phpunit/commit/284a69fb88a2d0845d23f42974a583d8f59bf5a5","https://github.com/sebastianbergmann/phpunit/commit/3aaddb1c5bd9b9b8d070b4cf120e71c36fd08412","https://github.com/FriendsOfPHP/security-advisories/blob/master/phpunit/phpunit/CVE-2017-9841.yaml","https://github.com/sebastianbergmann/phpunit","https://security.gentoo.org/glsa/201711-15","https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2017-9841","https://www.oracle.com/security-alerts/cpuoct2021.html","http://web.archive.org/web/20170701212357/http://phpunit.vulnbusters.com","http://www.securityfocus.com/bid/101798","http://www.securitytracker.com/id/1039812"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-r7c9-c69m-rph8","url":"https://osv.dev/vulnerability/GHSA-r7c9-c69m-rph8"},{"source":"kev","source_id":"CVE-2017-9841","url":"https://www.cisa.gov/sites/default/files/feeds/known_exploited_vulnerabilities.json"}],"summary":"Code Injection in PHPUnit"}