{"action":"Upgrade apache-airflow to 1.9.0 or later.","affected":[{"fixed":"1.9.0","introduced":"0"}],"component":"apache-airflow","cve_ids":["CVE-2017-15720"],"ecosystem":"PyPI","epss":0.02532,"exploited":false,"fixed_versions":["1.9.0"],"ghsa_id":"GHSA-8fg4-j562-mjrc","id":"tcs_01M5KF829Y3P78FVDBKNABQ31D","modified_at":"2024-09-09T21:49:47.930328Z","published_at":"2019-01-25T16:19:01Z","references":["https://osv.dev/vulnerability/GHSA-8fg4-j562-mjrc","https://nvd.nist.gov/vuln/detail/CVE-2017-15720","https://github.com/apache/airflow/commit/04cacdd0a7526927137b452f38c3e894a5d2ce4a","https://github.com/apache/airflow/commit/daa281c0364609d6812921123cf47e4118b40484","https://github.com/advisories/GHSA-8fg4-j562-mjrc","https://github.com/apache/airflow","https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2019-147.yaml","https://lists.apache.org/thread.html/ade4d54ebf614f68dc81a08891755e60ea58ba88e0209233eeea5f57@%3Cdev.airflow.apache.org%3E"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-8fg4-j562-mjrc","url":"https://osv.dev/vulnerability/GHSA-8fg4-j562-mjrc"}],"summary":"Improper Input Validation in Apache Airflow resulting in Remote Code Execution"}