{"action":"Upgrade vm2 to 3.11.7 or later.","affected":[{"fixed":"3.11.7","introduced":"3.11.3"}],"component":"vm2","cve_ids":["CVE-2026-92938"],"ecosystem":"npm","epss":0.00616,"exploited":false,"fixed_versions":["3.11.7"],"ghsa_id":"GHSA-6w8r-xxw2-g3hx","id":"tcs_01M5KF84M5ES4WJ8MMWBPEMMTW","modified_at":"2026-10-01T15:45:06.211098299Z","published_at":"2026-10-01T15:29:04Z","references":["https://osv.dev/vulnerability/GHSA-6w8r-xxw2-g3hx","https://github.com/patriksimek/vm2/security/advisories/GHSA-6w8r-xxw2-g3hx","https://nvd.nist.gov/vuln/detail/CVE-2026-92938","https://github.com/patriksimek/vm2/commit/aa146a77f859325e079f3bfbfe6d8309af483daa","https://github.com/patriksimek/vm2","https://github.com/patriksimek/vm2/releases/tag/v3.11.7","https://www.vulncheck.com/advisories/vm2-3.11.3-through-3.11.6-remote-code-execution-via-node-sqlite"],"severity":{"label":"critical","score":9.9},"sources":[{"source":"osv","source_id":"GHSA-6w8r-xxw2-g3hx","url":"https://osv.dev/vulnerability/GHSA-6w8r-xxw2-g3hx"}],"summary":"vm2 allows a sandboxed plugin to execute native code through `node:sqlite`"}