{"action":"Upgrade apache-airflow-providers-google to 8.10.0 or later.","affected":[{"fixed":"8.10.0","introduced":"0"}],"component":"apache-airflow-providers-google","cve_ids":["CVE-2023-25691"],"ecosystem":"PyPI","epss":0.01597,"exploited":false,"fixed_versions":["8.10.0"],"ghsa_id":"GHSA-8g23-2q5p-8866","id":"tcs_01M5KF85M5JBG6F05T8DQEBQ7K","modified_at":"2026-10-26T21:30:04.157195437Z","published_at":"2023-02-24T12:31:20Z","references":["https://osv.dev/vulnerability/GHSA-8g23-2q5p-8866","https://nvd.nist.gov/vuln/detail/CVE-2023-25691","https://github.com/apache/airflow/pull/29497","https://github.com/apache/airflow","https://lists.apache.org/thread/zdr8ovfttbh7kj0lydgcw88tbt2nmkcy","https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow-providers-google/PYSEC-2026-277.yaml","https://pypi.org/project/apache-airflow-providers-google"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-8g23-2q5p-8866","url":"https://osv.dev/vulnerability/GHSA-8g23-2q5p-8866"}],"summary":"Apache Airflow Google Provider Improper Input Validation vulnerability"}