{"action":"Upgrade ascii to 0.9.3 or later.","affected":[{"fixed":"0.9.3","introduced":"0.6.1-0"}],"component":"ascii","cve_ids":[],"ecosystem":"crates.io","exploited":false,"fixed_versions":["0.9.3"],"ghsa_id":"GHSA-mrrw-grhq-86gf","id":"tcs_01M5KF8BPM0RH7CVCM0A4N0YT2","modified_at":"2023-11-08T04:21:16.691544Z","published_at":"2023-02-25T12:00:00Z","references":["https://osv.dev/vulnerability/RUSTSEC-2023-0015","https://crates.io/crates/ascii","https://rustsec.org/advisories/RUSTSEC-2023-0015.html","https://github.com/tomprogrammer/rust-ascii/issues/64"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"RUSTSEC-2023-0015","url":"https://osv.dev/vulnerability/RUSTSEC-2023-0015"}],"summary":"Ascii allows out-of-bounds array indexing in safe code"}