{"action":"Upgrade salt to 2014.7.6 or later.","affected":[{"fixed":"2014.7.6","introduced":"0"}],"component":"salt","cve_ids":["CVE-2015-4017"],"ecosystem":"PyPI","epss":0.01078,"exploited":false,"fixed_versions":["2014.7.6"],"ghsa_id":"GHSA-8j9g-c9rp-jvg4","id":"tcs_01M5KF8E8AB3HJ1GYVWQA5HX25","modified_at":"2024-10-21T21:54:13.197904Z","published_at":"2022-05-14T03:07:28Z","references":["https://osv.dev/vulnerability/GHSA-8j9g-c9rp-jvg4","https://nvd.nist.gov/vuln/detail/CVE-2015-4017","https://bugzilla.redhat.com/show_bug.cgi?id=1222960","https://docs.saltstack.com/en/latest/topics/releases/2014.7.6.html","https://github.com/pypa/advisory-database/tree/main/vulns/salt/PYSEC-2017-31.yaml","https://github.com/saltstack/salt","https://groups.google.com/forum/#!topic/salt-users/8Kv1bytGD6c","http://www.openwall.com/lists/oss-security/2015/05/19/2"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-8j9g-c9rp-jvg4","url":"https://osv.dev/vulnerability/GHSA-8j9g-c9rp-jvg4"}],"summary":"Salt vulnerable to Improper Certificate Validation"}