{"action":"Upgrade upsonic to 0.56.0 or later.","affected":[{"fixed":"0.56.0","introduced":"0"}],"component":"upsonic","cve_ids":["CVE-2025-6278"],"ecosystem":"PyPI","epss":0.00702,"exploited":false,"fixed_versions":["0.56.0"],"ghsa_id":"GHSA-8jf4-fcjr-68c2","id":"tcs_01M5KF8EDPFEN36CM1EX8T5WXY","modified_at":"2025-07-09T01:42:08.501513Z","published_at":"2025-06-19T21:31:19Z","references":["https://osv.dev/vulnerability/GHSA-8jf4-fcjr-68c2","https://nvd.nist.gov/vuln/detail/CVE-2025-6278","https://github.com/Upsonic/Upsonic/issues/356","https://github.com/Upsonic/Upsonic/pull/360","https://github.com/Upsonic/Upsonic/commit/a54529acc6e4bfe28f4f5c80c058144348a306b7","https://github.com/Upsonic/Upsonic","https://github.com/Upsonic/Upsonic/blob/v0.55.6/src/upsonic/server/markdown/server/server.py#L39","https://github.com/pypa/advisory-database/tree/main/vulns/upsonic/PYSEC-2025-67.yaml","https://vuldb.com/?ctiid.313282","https://vuldb.com/?id.313282","https://vuldb.com/?submit.593096"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"GHSA-8jf4-fcjr-68c2","url":"https://osv.dev/vulnerability/GHSA-8jf4-fcjr-68c2"}],"summary":"Upsonic is vulnerable to Path Traversal attack through its os.path.join function"}