{"action":"Upgrade yiisoft/yii2-authclient to 2.2.15 or later.","affected":[{"fixed":"2.2.15","introduced":"0"}],"component":"yiisoft/yii2-authclient","cve_ids":["CVE-2023-50714"],"ecosystem":"Packagist","epss":0.00492,"exploited":false,"fixed_versions":["2.2.15"],"ghsa_id":"GHSA-rw54-6826-c8j5","id":"tcs_01M5KF8KSNRVA4W4E2C4SY5S3H","modified_at":"2026-09-10T03:50:09.131571556Z","published_at":"2023-12-18T19:34:20Z","references":["https://osv.dev/vulnerability/GHSA-rw54-6826-c8j5","https://github.com/yiisoft/yii2-authclient/security/advisories/GHSA-rw54-6826-c8j5","https://nvd.nist.gov/vuln/detail/CVE-2023-50714","https://github.com/yiisoft/yii2-authclient/commit/721ed974bc44137437b0cdc8454e137fff8db213","https://github.com/yiisoft/yii2-authclient","https://github.com/yiisoft/yii2-authclient/blob/0d1c3880f4d79e20aa1d77c012650b54e69695ff/src/OAuth1.php#L158","https://github.com/yiisoft/yii2-authclient/blob/0d1c3880f4d79e20aa1d77c012650b54e69695ff/src/OAuth2.php#L121","https://github.com/yiisoft/yii2-authclient/blob/0d1c3880f4d79e20aa1d77c012650b54e69695ff/src/OpenIdConnect.php#L420"],"severity":{"label":"medium","score":6.8},"sources":[{"source":"osv","source_id":"GHSA-rw54-6826-c8j5","url":"https://osv.dev/vulnerability/GHSA-rw54-6826-c8j5"}],"summary":"yiisoft/yii2-authclient's Oauth2 PKCE implementation is vulnerable"}