{"action":"Upgrade wp-cli/wp-cli to 2.5.0 or later.","affected":[{"fixed":"2.5.0","introduced":"0.12.0"}],"component":"wp-cli/wp-cli","cve_ids":["CVE-2021-29504"],"ecosystem":"Packagist","epss":0.01312,"exploited":false,"fixed_versions":["2.5.0"],"ghsa_id":"GHSA-rwgm-f83r-v3qj","id":"tcs_01M5KF8MVECNQPPQFYB20NZVVX","modified_at":"2026-07-08T06:28:33.162076980Z","published_at":"2021-05-19T23:03:11Z","references":["https://osv.dev/vulnerability/GHSA-rwgm-f83r-v3qj","https://github.com/wp-cli/wp-cli/security/advisories/GHSA-rwgm-f83r-v3qj","https://nvd.nist.gov/vuln/detail/CVE-2021-29504","https://github.com/wp-cli/checksum-command/pull/86","https://github.com/wp-cli/config-command/pull/128","https://github.com/wp-cli/core-command/pull/186","https://github.com/wp-cli/extension-command/pull/287","https://github.com/wp-cli/package-command/pull/138","https://github.com/wp-cli/wp-cli/pull/5523","https://github.com/FriendsOfPHP/security-advisories/blob/master/wp-cli/wp-cli/CVE-2021-29504.yaml"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"GHSA-rwgm-f83r-v3qj","url":"https://osv.dev/vulnerability/GHSA-rwgm-f83r-v3qj"}],"summary":"Improper Certificate Validation in WP-CLI framework"}