{"action":"Upgrade madge to 4.0.1 or later.","affected":[{"fixed":"4.0.1","introduced":"0"}],"component":"madge","cve_ids":["CVE-2021-23352"],"ecosystem":"npm","epss":0.02057,"exploited":false,"fixed_versions":["4.0.1"],"ghsa_id":"GHSA-753c-phhg-cj29","id":"tcs_01M5KF8SH8GG466N8X792CHFJK","modified_at":"2026-07-08T06:50:04.197327423Z","published_at":"2021-03-12T23:01:49Z","references":["https://osv.dev/vulnerability/GHSA-753c-phhg-cj29","https://nvd.nist.gov/vuln/detail/CVE-2021-23352","https://github.com/pahen/madge/commit/da5cbc9ab30372d687fa7c324b22af7ffa5c6332","https://github.com/pahen/madge/blob/master/lib/graph.js#L27","https://snyk.io/vuln/SNYK-JS-MADGE-1082875"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-753c-phhg-cj29","url":"https://osv.dev/vulnerability/GHSA-753c-phhg-cj29"}],"summary":"Madge vulnerable to command injection"}