{"action":"Upgrade moodle/moodle to 4.1.12 or later.","affected":[{"fixed":"4.1.12","introduced":"0"},{"fixed":"4.2.9","introduced":"4.2.0-beta"},{"fixed":"4.3.6","introduced":"4.3.0-beta"},{"fixed":"4.4.2","introduced":"4.4.0-beta"}],"component":"moodle/moodle","cve_ids":["CVE-2024-43425"],"ecosystem":"Packagist","epss":0.87536,"exploited":false,"fixed_versions":["4.1.12","4.2.9","4.3.6","4.4.2"],"ghsa_id":"GHSA-v6f4-v8h8-3c87","id":"tcs_01M5KF8W85CZ88W8FKBMWEZG32","modified_at":"2025-05-02T06:59:06.674664Z","published_at":"2024-11-07T15:31:52Z","references":["https://osv.dev/vulnerability/GHSA-v6f4-v8h8-3c87","https://nvd.nist.gov/vuln/detail/CVE-2024-43425","https://bugzilla.redhat.com/show_bug.cgi?id=2304253","https://github.com/moodle/moodle","https://moodle.org/mod/forum/discuss.php?d=461193","http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-82576"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"GHSA-v6f4-v8h8-3c87","url":"https://osv.dev/vulnerability/GHSA-v6f4-v8h8-3c87"}],"summary":"Moodle Remote Code Execution vulnerability"}