{"action":"Upgrade appwrite/server-ce to 0.11.1 or later.","affected":[{"fixed":"0.12.2","introduced":"0.12.0"},{"fixed":"0.11.1","introduced":"0"}],"component":"appwrite/server-ce","cve_ids":["CVE-2021-23682"],"ecosystem":"Packagist","epss":0.02117,"exploited":false,"fixed_versions":["0.12.2","0.11.1"],"ghsa_id":"GHSA-v9p9-535w-4285","id":"tcs_01M5KF9145HA20ER559WVK5ARM","modified_at":"2025-01-14T09:12:19.179146Z","published_at":"2022-02-17T00:00:32Z","references":["https://osv.dev/vulnerability/GHSA-v9p9-535w-4285","https://nvd.nist.gov/vuln/detail/CVE-2021-23682","https://github.com/appwrite/appwrite/pull/2778","https://github.com/litespeed-js/litespeed.js/pull/18","https://github.com/appwrite/appwrite/releases/tag/0.11.1","https://github.com/appwrite/appwrite/releases/tag/0.12.2","https://snyk.io/vuln/SNYK-JS-LITESPEEDJS-2359250","https://snyk.io/vuln/SNYK-PHP-APPWRITESERVERCE-2401820"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-v9p9-535w-4285#Packagist/appwrite/server-ce","url":"https://osv.dev/vulnerability/GHSA-v9p9-535w-4285"}],"summary":"Prototype Pollution in litespeed.js and appwrite/server-ce"}