{"action":"Upgrade whoami to 1.5.0 or later.","affected":[{"fixed":"1.5.0","introduced":"0.5.3"}],"component":"whoami","cve_ids":[],"ecosystem":"crates.io","exploited":false,"fixed_versions":["1.5.0"],"ghsa_id":"GHSA-w5w5-8vfh-xcjq","id":"tcs_01M5KF92Q3V8SCW09N38MKNF2J","modified_at":"2024-04-11T16:41:43.737392Z","published_at":"2024-02-28T12:00:00Z","references":["https://osv.dev/vulnerability/RUSTSEC-2024-0020","https://crates.io/crates/whoami","https://rustsec.org/advisories/RUSTSEC-2024-0020.html","https://github.com/ardaku/whoami/issues/91"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"RUSTSEC-2024-0020","url":"https://osv.dev/vulnerability/RUSTSEC-2024-0020"}],"summary":"Stack buffer overflow with whoami on several Unix platforms"}