{"action":"Upgrade phpseclib/phpseclib to 2.0.31 or later.","affected":[{"fixed":"3.0.7","introduced":"3.0.0"},{"fixed":"2.0.31","introduced":"0"}],"component":"phpseclib/phpseclib","cve_ids":["CVE-2021-30130"],"ecosystem":"Packagist","epss":0.01055,"exploited":false,"fixed_versions":["3.0.7","2.0.31"],"ghsa_id":"GHSA-vf4w-fg7r-5v94","id":"tcs_01M5KF93S10PQ2KSFSE988NYX9","modified_at":"2026-09-10T03:49:04.088139485Z","published_at":"2021-04-07T20:56:55Z","references":["https://osv.dev/vulnerability/GHSA-vf4w-fg7r-5v94","https://nvd.nist.gov/vuln/detail/CVE-2021-30130","https://github.com/phpseclib/phpseclib/pull/1635","https://github.com/FriendsOfPHP/security-advisories/blob/master/phpseclib/phpseclib/CVE-2021-30130.yaml","https://github.com/phpseclib/phpseclib/releases/tag/2.0.31","https://github.com/phpseclib/phpseclib/releases/tag/3.0.7","https://lists.debian.org/debian-lts-announce/2022/11/msg00024.html","https://lists.debian.org/debian-lts-announce/2022/11/msg00025.html"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-vf4w-fg7r-5v94","url":"https://osv.dev/vulnerability/GHSA-vf4w-fg7r-5v94"}],"summary":"Improper Certificate Validation in phpseclib"}