{"action":"Upgrade openpgp to 4.3.0 or later.","affected":[{"fixed":"4.3.0","introduced":"0"}],"component":"openpgp","cve_ids":["CVE-2019-9155"],"ecosystem":"npm","epss":0.01709,"exploited":false,"fixed_versions":["4.3.0"],"ghsa_id":"GHSA-77jf-fjjf-xcww","id":"tcs_01M5KF94X851RJKF8AX9MQT93N","modified_at":"2023-11-08T04:01:46.733717Z","published_at":"2019-08-23T21:42:22Z","references":["https://osv.dev/vulnerability/GHSA-77jf-fjjf-xcww","https://nvd.nist.gov/vuln/detail/CVE-2019-9155","https://github.com/openpgpjs/openpgpjs/pull/853","https://github.com/openpgpjs/openpgpjs/pull/853/commits/7ba4f8c655e7fd7706e8d7334e44b40fdf56c43e","https://github.com/openpgpjs/openpgpjs/releases/tag/v4.3.0","https://sec-consult.com/en/blog/advisories/multiple-vulnerabilities-in-openpgp-js","https://snyk.io/vuln/SNYK-JS-OPENPGP-460225","https://www.bsi.bund.de/SharedDocs/Downloads/EN/BSI/Publications/Studies/Mailvelope_Extensions/Mailvelope_Extensions_pdf.html#download=1","https://www.npmjs.com/advisories/1159","http://packetstormsecurity.com/files/154191/OpenPGP.js-4.2.0-Signature-Bypass-Invalid-Curve-Attack.html"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"GHSA-77jf-fjjf-xcww","url":"https://osv.dev/vulnerability/GHSA-77jf-fjjf-xcww"}],"summary":"Invalid Curve Attack in openpgp"}