{"action":"Upgrade flask-cors to 6.0.0 or later.","affected":[{"fixed":"6.0.0","introduced":"0"}],"component":"flask-cors","cve_ids":["CVE-2024-6844"],"ecosystem":"PyPI","epss":0.00319,"exploited":false,"fixed_versions":["6.0.0"],"ghsa_id":"GHSA-8vgw-p6qm-5gr7","id":"tcs_01M5KF94Y2T98N3K3ESNMX3HNR","modified_at":"2026-09-10T03:50:23.027959228Z","published_at":"2025-03-20T12:32:45Z","references":["https://osv.dev/vulnerability/GHSA-8vgw-p6qm-5gr7","https://nvd.nist.gov/vuln/detail/CVE-2024-6844","https://github.com/corydolphin/flask-cors/commit/35d875319621bd129a38b2b823abf4a2f6cda536","https://github.com/corydolphin/flask-cors","https://github.com/corydolphin/flask-cors/blob/main/flask_cors/extension.py#L193","https://huntr.com/bounties/731a6cd4-d05f-4fe6-8f5b-fe088d7b34e0","https://lists.debian.org/debian-lts-announce/2025/05/msg00049.html"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-8vgw-p6qm-5gr7","url":"https://osv.dev/vulnerability/GHSA-8vgw-p6qm-5gr7"}],"summary":"Flask-CORS allows for inconsistent CORS matching"}