{"action":"Upgrade diesel to 2.2.3 or later.","affected":[{"fixed":"2.2.3","introduced":"0.0.0-0"}],"component":"diesel","cve_ids":[],"ecosystem":"crates.io","exploited":false,"fixed_versions":["2.2.3"],"ghsa_id":"GHSA-wq9x-qwcq-mmgf","id":"tcs_01M5KF9AC575TZV8XBXVXZ7HKY","modified_at":"2025-10-28T06:29:26.412332Z","published_at":"2024-08-23T12:00:00Z","references":["https://osv.dev/vulnerability/RUSTSEC-2024-0365","https://crates.io/crates/diesel","https://rustsec.org/advisories/RUSTSEC-2024-0365.html","https://github.com/diesel-rs/diesel/pull/4170"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"RUSTSEC-2024-0365","url":"https://osv.dev/vulnerability/RUSTSEC-2024-0365"}],"summary":"Binary Protocol Misinterpretation caused by Truncating or Overflowing Casts"}