{"action":"Upgrade flowise to 3.0.6 or later.","affected":[{"fixed":"3.0.6","introduced":"3.0.5"}],"component":"flowise","cve_ids":["CVE-2025-57164"],"ecosystem":"npm","epss":0.00637,"exploited":false,"fixed_versions":["3.0.6"],"ghsa_id":"GHSA-7944-7c6r-55vv","id":"tcs_01M5KF9DRB4MV70V1TKCHTCQQP","modified_at":"2025-10-17T20:44:44.249658Z","published_at":"2025-09-15T19:51:08Z","references":["https://osv.dev/vulnerability/GHSA-7944-7c6r-55vv","https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-7944-7c6r-55vv","https://nvd.nist.gov/vuln/detail/CVE-2025-57164","https://github.com/FlowiseAI/Flowise","https://github.com/FlowiseAI/Flowise/blob/flowise%403.0.5/packages/components/nodes/vectorstores/Supabase/Supabase.ts#L237","https://github.com/FlowiseAI/Flowise/blob/main/packages/components/nodes/vectorstores/Supabase/Supabase.ts#L237","https://github.com/FlowiseAI/Flowise/releases/tag/flowise%403.0.6"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"GHSA-7944-7c6r-55vv","url":"https://osv.dev/vulnerability/GHSA-7944-7c6r-55vv"}],"summary":"FlowiseAI Pre-Auth Arbitrary Code Execution"}