{"action":"Upgrade prestashop/ps_emailsubscription to 2.6.1 or later.","affected":[{"fixed":"2.6.1","introduced":"0"}],"component":"prestashop/ps_emailsubscription","cve_ids":["CVE-2021-21418"],"ecosystem":"Packagist","epss":0.00786,"exploited":false,"fixed_versions":["2.6.1"],"ghsa_id":"GHSA-vwfx-hh3w-fj99","id":"tcs_01M5KF9GTFP0HQQ1345119CTXT","modified_at":"2026-07-08T06:27:33.161549592Z","published_at":"2021-04-06T17:24:14Z","references":["https://osv.dev/vulnerability/GHSA-vwfx-hh3w-fj99","https://github.com/PrestaShop/ps_emailsubscription/security/advisories/GHSA-vwfx-hh3w-fj99","https://nvd.nist.gov/vuln/detail/CVE-2021-21418","https://github.com/PrestaShop/ps_emailsubscription/commit/664ffb225e2afb4a32640bbedad667dc6e660b70","https://github.com/PrestaShop/ps_emailsubscription/releases/tag/v2.6.1","https://packagist.org/packages/prestashop/ps_emailsubscription"],"severity":{"label":"medium","score":4.6},"sources":[{"source":"osv","source_id":"GHSA-vwfx-hh3w-fj99","url":"https://osv.dev/vulnerability/GHSA-vwfx-hh3w-fj99"}],"summary":"Potential XSS injection in the newsletter conditions field"}