{"action":"Upgrade langchain to 0.0.236 or later.","affected":[{"fixed":"0.0.236","introduced":"0"}],"component":"langchain","cve_ids":["CVE-2023-38896"],"ecosystem":"PyPI","epss":0.01838,"exploited":false,"fixed_versions":["0.0.236"],"ghsa_id":"GHSA-92j5-3459-qgp4","id":"tcs_01M5KF9H93QXTZ8J0FTC1DT816","modified_at":"2024-09-27T21:48:10.474794Z","published_at":"2023-08-15T18:31:32Z","references":["https://osv.dev/vulnerability/GHSA-92j5-3459-qgp4","https://nvd.nist.gov/vuln/detail/CVE-2023-38896","https://github.com/hwchase17/langchain/issues/5872","https://github.com/hwchase17/langchain/pull/6003","https://github.com/langchain-ai/langchain/commit/8ba9835b925473655914f63822775679e03ea137","https://github.com/langchain-ai/langchain/commit/e294ba475a355feb95003ed8f1a2b99942509a9e","https://github.com/langchain-ai/langchain","https://github.com/pypa/advisory-database/tree/main/vulns/langchain/PYSEC-2023-146.yaml","https://twitter.com/llm_sec/status/1668711587287375876"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-92j5-3459-qgp4","url":"https://osv.dev/vulnerability/GHSA-92j5-3459-qgp4"}],"summary":"LangChain vulnerable to arbitrary code execution"}