{"action":"Upgrade rustyscript to 0.6.1 or later.","affected":[{"fixed":"0.6.1","introduced":"0.3.1-0"}],"component":"rustyscript","cve_ids":[],"ecosystem":"crates.io","exploited":false,"fixed_versions":["0.6.1"],"ghsa_id":"GHSA-fwfx-rrv8-crpf","id":"tcs_01M5KF9HF2WS8X38D8TVQX8KPC","modified_at":"2025-10-28T06:29:24.524094Z","published_at":"2024-07-18T12:00:00Z","references":["https://osv.dev/vulnerability/RUSTSEC-2024-0405","https://crates.io/crates/rustyscript","https://rustsec.org/advisories/RUSTSEC-2024-0405.html","https://github.com/rscarson/rustyscript/issues/174"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"RUSTSEC-2024-0405","url":"https://osv.dev/vulnerability/RUSTSEC-2024-0405"}],"summary":"op_panic in the base runtime can force a panic in the runtime's containing thread"}