{"action":"Upgrade flightphp/core to 3.18.1 or later.","affected":[{"fixed":"3.18.1","introduced":"0"}],"component":"flightphp/core","cve_ids":["CVE-2026-42551"],"ecosystem":"Packagist","epss":0.00351,"exploited":false,"fixed_versions":["3.18.1"],"ghsa_id":"GHSA-vxrr-w42w-w76g","id":"tcs_01M5KF9K8SJ4FZBFT4FQNCTTVB","modified_at":"2026-05-14T20:52:31.715224Z","published_at":"2026-05-06T21:38:16Z","references":["https://osv.dev/vulnerability/GHSA-vxrr-w42w-w76g","https://github.com/flightphp/core/security/advisories/GHSA-vxrr-w42w-w76g","https://nvd.nist.gov/vuln/detail/CVE-2026-42551","https://github.com/flightphp/core/commit/b8dd23aaa828cb289fa3c84e75b2a3717cab50b0","https://github.com/flightphp/core","https://github.com/flightphp/core/releases/tag/v3.18.1"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-vxrr-w42w-w76g","url":"https://osv.dev/vulnerability/GHSA-vxrr-w42w-w76g"}],"summary":"Flight: HTTP method override enabled by default, facilitating CSRF escalation and middleware bypass"}