{"action":"Upgrade octoprint to 1.8.3 or later.","affected":[{"fixed":"1.8.3","introduced":"0"}],"component":"octoprint","cve_ids":["CVE-2022-2888"],"ecosystem":"PyPI","epss":0.00295,"exploited":false,"fixed_versions":["1.8.3"],"ghsa_id":"GHSA-937f-qh3w-6g87","id":"tcs_01M5KF9KF717EBB1RVQ1PF9G1V","modified_at":"2024-10-08T13:04:57.118601Z","published_at":"2022-09-22T00:00:31Z","references":["https://osv.dev/vulnerability/GHSA-937f-qh3w-6g87","https://nvd.nist.gov/vuln/detail/CVE-2022-2888","https://github.com/octoprint/octoprint/commit/40e6217ac1a85cc5ed592873ae49db01d3005da4","https://github.com/octoprint/octoprint","https://github.com/pypa/advisory-database/tree/main/vulns/octoprint/PYSEC-2022-282.yaml","https://huntr.dev/bounties/d27d232b-2578-4b32-b3b4-74aabdadf629"],"severity":{"label":"medium","score":4.4},"sources":[{"source":"osv","source_id":"GHSA-937f-qh3w-6g87","url":"https://osv.dev/vulnerability/GHSA-937f-qh3w-6g87"}],"summary":"OctoPrint vulnerable to Insufficient Session Expiration."}