{"action":"Upgrade glib to 0.20.0 or later.","affected":[{"fixed":"0.20.0","introduced":"0.15.0"}],"component":"glib","cve_ids":[],"ecosystem":"crates.io","exploited":false,"fixed_versions":["0.20.0"],"ghsa_id":"GHSA-wrw7-89jp-8q8g","id":"tcs_01M5KF9KPMNEPPT551BKQPXDK5","modified_at":"2025-10-28T06:29:26.473225Z","published_at":"2024-03-30T12:00:00Z","references":["https://osv.dev/vulnerability/RUSTSEC-2024-0429","https://crates.io/crates/glib","https://rustsec.org/advisories/RUSTSEC-2024-0429.html","https://github.com/gtk-rs/gtk-rs-core/pull/1343"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"RUSTSEC-2024-0429","url":"https://osv.dev/vulnerability/RUSTSEC-2024-0429"}],"summary":"Unsoundness in `Iterator` and `DoubleEndedIterator` impls for `glib::VariantStrIter`"}