{"action":"Upgrade vega-interpreter to 1.2.1 or later.","affected":[{"fixed":"2.2.1","introduced":"2.0.0"},{"fixed":"1.2.1","introduced":"0"}],"component":"vega-interpreter","cve_ids":["CVE-2025-59840"],"ecosystem":"npm","epss":0.00424,"exploited":false,"fixed_versions":["2.2.1","1.2.1"],"ghsa_id":"GHSA-7f2v-3qq3-vvjf","id":"tcs_01M5KF9QFHQ2C4GJVHRPFMYPPR","modified_at":"2026-09-10T03:50:30.703548138Z","published_at":"2025-11-13T22:32:35Z","references":["https://osv.dev/vulnerability/GHSA-7f2v-3qq3-vvjf","https://github.com/vega/vega/security/advisories/GHSA-7f2v-3qq3-vvjf","https://nvd.nist.gov/vuln/detail/CVE-2025-59840","https://github.com/vega/editor/blob/e102355589d23cdd0dbfd607a2cc5f9c5b7a4c55/src/components/renderer/renderer.tsx#L239","https://github.com/vega/editor/blob/e102355589d23cdd0dbfd607a2cc5f9c5b7a4c55/src/index.tsx#L14-L16","https://github.com/vega/vega","https://vega.github.io/editor/#/url/vega/N4IgJAzgxgFgpgWwIYgFwhgF0wBwqgegIDc4BzJAOjIEtMYBXAI0poHsDp5kTykSArJQBWENgDsQAGhAB3GgBN6aAMwCADDPg0yWVRplIGmNhBoAvOGhDiJVmQrjQATjRyZ2k9ABU2ZMgA2cAAEAELGJpIyZmTiSAEQaADaoHEIVugm-kHSIMTxDBmYzoUyEsmgcKTimImooJgAnjgZIFABNFAA1rnIzl1prVA0zu1WAL4yDDgKSJitWYEhAPzBAGbxECGowcWFIOMAupOpSOnWSAoKAGI0AfPOueWoKSBVcDV1Dc2tCGwMWz+pFyYgYo1a8nECjYsgOUxmc1aAApgCYAMrFGjiMiod41SjEGhwWSUABqAFEAOIAQQA+gARcmhACqlIJfEoAGEkOJ8hAABI8hRBZyUHDONgmJotSgSKTBPGYAByZzguOqmAJRJJUAkYiClACfiktJgQpF+GADChcDWWLgClQAHJ4nBnJgkWxXLRxMEANTBAAGwQAGmi0cEJMFSM4zFHAwGKTSGUzWWSqXSKQAlNEASQA8kqAJROyam81u3M2gAe6o+msJxMoVXi4yLfoAjAdjscgA","https://vega.github.io/vega/usage/interpreter"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"GHSA-7f2v-3qq3-vvjf#npm/vega-interpreter","url":"https://osv.dev/vulnerability/GHSA-7f2v-3qq3-vvjf"}],"summary":"Vega Cross-Site Scripting (XSS) via expressions abusing toString calls in environments using the VEGA_DEBUG global variable"}