{"action":"Upgrade github.com/consensys/gnark-crypto to 0.12.0 or later.","affected":[{"fixed":"0.12.0","introduced":"0"}],"component":"github.com/consensys/gnark-crypto","cve_ids":["CVE-2023-44273"],"ecosystem":"Go","epss":0.01055,"exploited":false,"fixed_versions":["0.12.0"],"ghsa_id":"GHSA-fr8m-434r-g3xp","id":"tcs_01M5KF9RGNYXM7GFETYJQVD0T5","modified_at":"2026-02-03T03:09:38.161797Z","published_at":"2025-10-15T18:57:59Z","references":["https://osv.dev/vulnerability/GHSA-fr8m-434r-g3xp","https://github.com/Consensys/gnark-crypto/security/advisories/GHSA-fr8m-434r-g3xp","https://nvd.nist.gov/vuln/detail/CVE-2023-44273","https://github.com/Consensys/gnark-crypto/pull/449","https://github.com/Consensys/gnark-crypto","https://github.com/Consensys/gnark-crypto/releases/tag/v0.12.0","https://go.dev/blog/defer-panic-and-recover"],"severity":{"label":"medium","score":5.1},"sources":[{"source":"osv","source_id":"GHSA-fr8m-434r-g3xp","url":"https://osv.dev/vulnerability/GHSA-fr8m-434r-g3xp"}],"summary":"gnark-crypto doesn't range check input values during ECDSA and EdDSA signature deserialization"}