{"action":"Upgrade pear/http_request2 to 2.7.0 or later.","affected":[{"fixed":"2.7.0","introduced":"0"}],"component":"pear/http_request2","cve_ids":["CVE-2025-43717"],"ecosystem":"Packagist","epss":0.00335,"exploited":false,"fixed_versions":["2.7.0"],"ghsa_id":"GHSA-w7gh-f2fm-9q8r","id":"tcs_01M5KF9VFPNPQ4AHDNCH5XEDNR","modified_at":"2025-04-17T14:27:28.058766Z","published_at":"2025-04-17T03:30:30Z","references":["https://osv.dev/vulnerability/GHSA-w7gh-f2fm-9q8r","https://nvd.nist.gov/vuln/detail/CVE-2025-43717","https://github.com/pear/HTTP_Request2/commit/07925aa77e441dba0ff0fa973a09802729cb838f","https://github.com/pear/HTTP_Request2/commit/265e05f9e08a28a38a57219516a8e4e2dfdbb147","https://github.com/pear/HTTP_Request2","https://github.com/pear/HTTP_Request2/blob/b1c61b71128045734d757c4d3d436457ace80ea7/package.xml#L24","https://github.com/pear/HTTP_Request2/compare/v2.6.0...v2.7.0"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-w7gh-f2fm-9q8r","url":"https://osv.dev/vulnerability/GHSA-w7gh-f2fm-9q8r"}],"summary":"PEAR HTTP_Request2 vulnerable to Cross-site Scripting"}