{"action":"Upgrade next to 14.2.15 or later.","affected":[{"fixed":"14.2.15","introduced":"9.5.5"}],"component":"next","cve_ids":["CVE-2024-51479"],"ecosystem":"npm","epss":0.03995,"exploited":false,"fixed_versions":["14.2.15"],"ghsa_id":"GHSA-7gfc-8cq8-jh5f","id":"tcs_01M5KF9Z2Z7CY0H9R0S2R4P9QM","modified_at":"2025-09-10T21:12:24Z","published_at":"2024-12-17T15:09:06Z","references":["https://osv.dev/vulnerability/GHSA-7gfc-8cq8-jh5f","https://github.com/vercel/next.js/security/advisories/GHSA-7gfc-8cq8-jh5f","https://nvd.nist.gov/vuln/detail/CVE-2024-51479","https://github.com/vercel/next.js/commit/1c8234eb20bc8afd396b89999a00f06b61d72d7b","https://github.com/vercel/next.js","https://github.com/vercel/next.js/releases/tag/v14.2.15"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-7gfc-8cq8-jh5f","url":"https://osv.dev/vulnerability/GHSA-7gfc-8cq8-jh5f"}],"summary":"Next.js authorization bypass vulnerability"}