{"action":"Upgrade tensorflow-gpu to 2.3.4 or later.","affected":[{"fixed":"2.3.4","introduced":"0"},{"fixed":"2.4.3","introduced":"2.4.0"},{"fixed":"2.5.1","introduced":"2.5.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-37670"],"ecosystem":"PyPI","epss":0.00169,"exploited":false,"fixed_versions":["2.3.4","2.4.3","2.5.1"],"ghsa_id":"GHSA-9697-98pf-4rw7","id":"tcs_01M5KF9ZB38C8JF6V2MC5C0NBK","modified_at":"2026-07-08T06:29:57.921299912Z","published_at":"2021-08-25T14:41:44Z","references":["https://osv.dev/vulnerability/GHSA-9697-98pf-4rw7","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-9697-98pf-4rw7","https://nvd.nist.gov/vuln/detail/CVE-2021-37670","https://github.com/tensorflow/tensorflow/commit/42459e4273c2e47a3232cc16c4f4fff3b3a35c38","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-583.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-781.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-292.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"GHSA-9697-98pf-4rw7#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-9697-98pf-4rw7"}],"summary":"Heap OOB in `UpperBound` and `LowerBound`"}