{"action":"Upgrade appwrite/server-ce to 0.12.2 or later.","affected":[{"fixed":"0.12.2","introduced":"0.5.0"}],"component":"appwrite/server-ce","cve_ids":["CVE-2022-25377"],"ecosystem":"Packagist","epss":0.00793,"exploited":false,"fixed_versions":["0.12.2"],"ghsa_id":"GHSA-wfm3-gq9h-mrjm","id":"tcs_01M5KFA1251D4X3Y9HS2TCJ65Z","modified_at":"2024-08-21T22:04:35.666645Z","published_at":"2024-02-23T00:30:33Z","references":["https://osv.dev/vulnerability/GHSA-wfm3-gq9h-mrjm","https://nvd.nist.gov/vuln/detail/CVE-2022-25377","https://github.com/appwrite/appwrite/pull/2780","https://github.com/appwrite/appwrite/commit/892f6fa4ba0d44e2435ffad1a84542400cfb7a9b","https://dubell.io/unauthenticated-lfi-in-appwrite-0.5.0-0.12.1","https://github.com/appwrite/appwrite","https://github.com/appwrite/appwrite/blob/0.12.0/app/controllers/general.php#L539","https://github.com/appwrite/appwrite/releases/tag/0.12.2"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-wfm3-gq9h-mrjm","url":"https://osv.dev/vulnerability/GHSA-wfm3-gq9h-mrjm"}],"summary":"Appwrite Directory Traversal vulnerability"}